0

I very recently updated to Emacs 26.3 and Org 9.2.6, and am getting the above-mentioned error whenever I type "[[" in an org-mode buffer to type a hyperlink. Unsurprisingly, no error after turning off auto-complete mode (20170125.245, the only version I see in "list-packages").

Any possible fixes or recommendations?

Addendum 1: Aside from the error message, the link still works fine.

Addendum 2: Searching through the variable index of the Org manual, there's no mention of "org-link-types". The second line of the debugger backtrace cites "org-ac--get-link-head-candidates()". The hyperlink takes me to the function's definition in "org-ac.el" where there's a line (mapcar (lambda (x) (concat x ":")) org-link-types))). Is it reasonable to assume this is what's causing the problem? And if so, is there anything to be done about it?

  • Check your code (starting with your init file) for that variable. Sounds like it is maybe no longer available/used by Org. First, start Emacs using emacs -Q, to see the problem reproduces without your init file. If it doesn't, bisect your init file to find the culprit. – Drew Oct 25 '19 at 14:54
  • Searching through the variable index of the Org manual, there's no mention of "org-link-types". The second line of the debugger backtrace cites "org-ac--get-link-head-candidates()". The hyperlink takes me to the function's definition in "org-ac.el" where there's a line (mapcar (lambda (x) (concat x ":")) org-link-types))). Is it reasonable to assume this is what's causing the problem? And if so, is there anything to be done about it? – granti128 Oct 26 '19 at 6:06
  • Please add such info to your question, if you think it's relevant to it. Comments can be deleted any time. – Drew Oct 26 '19 at 16:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.