3

Say I have a file named foo in directory bar. I also have helm-mode enabled and am trying to rename foo to fo through dired. Rename here ends up opening helm-mode-dired-do-rename and on typing fo, the only helm candidate is foo. How do I tell helm that the name I want to use is fo?

  • You issue seems to be similar to this one. Try pressing C-<backspace> to disable automatic completion and then type in the new name. (Let me know if this works: I don't have the time to test this myself right now.) – Constantine Dec 12 '14 at 20:27
  • @Constantine No, that doesn't work. The word I am typing doesn't get auto-expanded. However, as long as helm finds a match for my input, pressing RET ends up selecting that match, instead of using my input as is. – Pradhan Dec 12 '14 at 22:17
  • @Constantine C-c ? in that helm window says "autoupdate may keep updating to an existent directory preventing you from creating a new directory. In this case, just hit C-<backspace> and then <backspace>. This should not be needed when copying/renaming files because autoupdate is disabled by default in this case." – Pradhan Dec 12 '14 at 22:23
  • I use C-c <backspace> to disable auto-expansion in Helm. I use Emacs mainly in console mode within tmux sessions. – rimero Dec 12 '14 at 22:37
  • @rimero auto-expansion is already disabled. When I type either C-c <backspace> or C-<backspace> it says [Auto expansion enabled] and I need to toggle it again. – Pradhan Dec 12 '14 at 22:43
3

Select foo R, enter the new name (fo in this case) and C-p (to select [?]fo candidate) RET.

| improve this answer | |
  • This is the correct answer. – Tu Do Dec 15 '14 at 6:17
  • <facepalm> Can't believe I didn't try this :) Thanks! – Pradhan Dec 16 '14 at 20:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.