0

I'm on macOS Catalina, and I'm using Emacs for Mac OS X. When I click File > Open, or the Open button on the toolbar, or "Open a File" on the splash screen, I get a crash.

I have tried some other Emacs distributions, namely:

  • emacs --with-cocoa installed via Homebrew
  • emacs-plus installed via Homebrew

I have granted file system access to the various executables for each distribution, and all three options give the same errors.

Here's the part of the crash report that I think is most helpful:

Application Specific Information:
*** Terminating app due to uncaught exception 'NSObjectNotAvailableException',
reason: 'EmacsSavePanel is not a supported subclass for sandboxing'
abort() called
terminating with uncaught exception of type NSException

From the crash report, I thought the problem was with file system access. I followed the steps in this question, but giving /usr/bin/ruby full disk access did not fix the problem. I've also tried giving the following full disk access, but so far no success:

  • The Emacs app
  • the Emacs executable inside the Emacs app
  • The Homebrew install of Ruby (both /usr/local/bin/ruby and /usr/local/Cellar/ruby/2.6.5/bin/ruby

Is there something else I should be looking for?

2
  • I suggest to use Homebrew to install emacs-plus from this site: github.com/d12frosted/homebrew-emacs-plus. That does not exhibit such problem. Further, when opening and accessing, IIRC, will ask for giving permission, and the results will be shown in Setting -> Security & Privacy -> Privacy -> File and Folders. If not, manually add Emacs there (I do not remember to do it manually in my case...).
    – Ian
    Oct 30, 2019 at 15:33
  • Thanks Ian. I have tried emacs-plus, the "regular" emacs via Homebrew, and emacs --with-cocoa, which appears to just download the Emacs for Mac OS X package. All give the same result. None ask for permission and adding permission manually via Settings > Security & Privacy > Privacy > Full Disk Access does not fix the issue either. I will add some of this info to my question.
    – dixius99
    Oct 30, 2019 at 16:07

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.