1

I use mu4e and Emacs for email, as well as GPG for credentials and mu4e-send-delay for delayed sending.

Sometimes the GPG prompt for the encryption password is overwritten by another message in the mini-buffer, and GPG gets the wrong password. The mini-buffer shows Blocking call to accept-process-output with quit inhibited! and a pop-up dialog says Buffer *temp* modified, kill anyway?. A copy of the message is saved in the home directory with filepath ~/*message*-20191031-185747.

This pop-up appears as many times as the number of emails to send and comes again after the value of mu4e-send-delay-timer (60 seconds in my case).

The only solution I found (from How to force Emacs or pinentry to forget wrong GPG password?) was to kill the GPG agent with gpgconf --kill gpg-agent and restart Emacs. Either of them alone is not enough, I need to do both. Then I get prompted for a GPG password.

I am using GNU Emacs 26.3, gpg 2.2.17, and macOS Mojave 10.14.6.

How can I set up Emacs, mu4e, and GPG to be more user-friendly, maybe with a pop-up to request the password, and setting GPG to forget wrong passwords?

  • what os are you using? I still have a response on other question pending, but time has been very scarce lately. – Muihlinn Nov 2 '19 at 18:16
  • I updated the question. @Muihlinn, yes, the question is similar to a question in a comment in emacs.stackexchange.com/questions/52837/… . – miguelmorin Nov 3 '19 at 10:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.