2

I am using a dark theme and the latex previews from auctex are created with black text color. How can I change it? What I can do is change the background color to white (in Preview Reference Face customization), then I can at least read the text but it is irritating. Setting the foreground there did not work for me.

I also already tried to inject \color{white} into the latex commands somehow but without luck. Where would be the right place?

0

Checkout the preview-pdf-color-adjust-method option.

Apparently it should use automatically the same foreground color as the buffer text, but at least in my case the problem was that I have only Ghostscript 9.26 installed. As a workaround I downloaded the latest Ghostscript binary and modified preview-gs-command to point to it.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.