1

enter image description here

See the screenshot. I typed one long line in the buffer, didn't hit enter but cursor is already on line 3.

This causes multiple problems, eg. when I copy the output of a command from ansi-term to another buffer then it's copied with these additional newlines.

My expectation is that cursor in the above example would still stay at line 1. How can I make ansi-term work like that?

  • 1
    You want to set the term-width variable. Usually you'd do this in a hook, but it doesn't work for term-mode -- it mus be setting the variable after the hook. I tried using advice as some other answers on this forum recommend, but that didn't work either. – markasoftware Nov 21 '19 at 23:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.