2

Occasionally the minibuffer acts somewhat like a "regular" buffer. By that I mean that when I type C-x o my cursor jumps to that buffer and then waits for me to type something.

But I can't write anything to it. For example, when I type n a new frame is opened.

The label for this buffer seems to be *Minibuf-0* - it is a minibuffer.

(Messages are still printed OK to the echo area, which is in the same location as the minibuffer.)

What I would like to do is "reset" the minibuffer so that it acts normally. I tried killing that buffer with C-x k but that doesn't change anything. The only thing that seems to fix it is a reboot of Emacs.

Is there a way to "reset" the minibuffer?

4
  • 1
    The n binding comes from minibuffer-inactive-mode-map. AFAIK this is normally only used for those special frames which only contain a minibuffer. I think what you're seeing is a bug and I'd recommend you M-x report-emacs-bug. If you can find a way to reproduce the problem that would be particularly helpful to track downb and fix the bug.
    – Stefan
    Nov 22, 2019 at 17:29
  • Edited the question. It's about the minibuffer, not the echo area. One indication that there might be a bug is that the problem goes away (temporarily) if you reboot. Does it also go away if you just quit Emacs and restart Emacs (without rebooting)? Anyway, as @Stefan said, please do report this behavior, preferably with a recipe that starts from emacs -Q (no init file).
    – Drew
    Nov 22, 2019 at 18:11
  • 1
    Have you tried M-x top-level?
    – NickD
    Nov 22, 2019 at 18:27
  • Thank you for all of your suggestions. @Drew - I feel that your edit will make the question harder to find for people whose echo area "turns into" a minibuffer. Am I misunderstanding the terminology? When I say "reboot" I mean it jokingly. I can actually reboot my computer faster than I can start Emacs on my Windows system. I just meant restarting Emacs. When it happens again I will make a bug report. Thank you all for your help.
    – Tom Purl
    Nov 25, 2019 at 14:47

1 Answer 1

4

@NickD had the answer! When my echo area "turns into" a minibuffer, I simply choose that buffer and execute the top-level function and the problem is solved. Thanks a ton for the help!

1
  • That may have enabled you to get out of the situation you were in. But your description of that situation suggests that there's a problem - perhaps a bug. and you said that this happens occasionally - it wasn't just a one-off.
    – Drew
    Nov 25, 2019 at 17:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.