When I try to export an Org mode document to OpenOffice Document format, I get the following error:

Screenshot 1

This answer suggested to use 7zip. So I

  1. installed 7zip,
  2. copied 7z.exe and renamed the copy to zip.exe, and
  3. added the path of 7zip (C:\Program Files\7-Zip) to exec-path (via M-x customize-variable RET exec-path RET).

But when I try to export my Org mode file to ODT with this setup, I get an error Incorrect command line, probably because 7zip uses different command line arguments than the zip program Org mode expects.

Screenshot 2

How can I fix this?

  • How about using zip instead of 7zip? Renaming a program from "orange" to "banana" does not make the program a "banana"; i.e., it is an "orange" disguised as a "banana" and your computer knows it and that is why it is saying "Error: Incorrect command line".
    – lawlist
    Nov 24, 2019 at 17:17
  • 1
    Here is a link to a thread that seems applicable: lists.gnu.org/archive/html/emacs-orgmode/2013-04/msg00423.html
    – lawlist
    Nov 24, 2019 at 17:22
  • @lawlist Where can I get that zip for Windows? Cygwin? Nov 25, 2019 at 8:32
  • Have you already read through the linked thread and tried out the recommendations? There are five (5) posts including the initial question in that thread ....
    – lawlist
    Nov 25, 2019 at 8:49

1 Answer 1


Here is a short tutorial for all who want to use ODT export under Windows.

  1. I downloaded :

zip and unzip

  1. Extracted zip300xn.zip in a folder zip300xn and executed unz600xn.exe in a folder unz600xn

  2. Put those two folders in C:\Program Files\zip300xn and C:\Program Files\unz600xn.

I set the exec-path variable as shown below using M-x customize-variable RET exec-path RET.

exec-path variable

When I try to export an Org Mode document to OpenOffice.org, I get the following error:

Error message

Then I changed the paths in exec-path to the following:

exec-path values 2

Translation from German:

Command C:\Program is either spelled wrongly or could not be found.

Then I moved zip300xn and unz600xn to C:/EmacsInfrastructure and set the exec-path variable accordingly.

Still no luck: unzip.exe could not be found in C:/EmacsInfrastructure/zip300xn.

Copied unzip.exe and unzip.txt from EmacsInfrastructure\unz600xn to C:/EmacsInfrastructure/zip300xn.

Then it worked.

  • In the second link to "2. unzip" you have to select the two files to download "unzip.exe" and "unzip.txt". First I downloaded "unz600xn.exe" and this did not work. Thanks for the Solution Dimitrii! Apr 1, 2022 at 15:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.