1

When using company in shell-mode, a space is added after a match is made. This makes path completions behave badly, since I simply can't continue with the next directory but have to go back. I guess this behaviour is due to that when completing a command, you want the extra space.

I assume someone has already solved this, in order to get the usual path completion behaviour, but still use company in shell-mode.

(If my description was unclear, say I want to list /some_directory/another_direcory/file.txt. I type ls /some. I can now select /some_directory/ as completion. Now I have ls /some_directory/ (node trailing space). I have to press backspace in order continue with another_directory.)

I've tried with emacs -Q and then enabled global-company-mode. The shell I get from M-x shell gives the same behaviour.

  • I was not able to reproduce this behaviour, could you try with bare emacs (emacs -Q) with only company mode loaded? – Iqbal Ansari Dec 15 '14 at 13:49
  • @IqbalAnsari: I get the same behaviour with emacs -Q. – Meaningful Username Dec 15 '14 at 14:06
  • This used to happen to me. I'm not sure what fixed it. Maybe try updating company? – nanny Dec 15 '14 at 14:08
  • @nanny: I just enabled it last week, it's version 0.8.7. – Meaningful Username Dec 15 '14 at 14:15
  • 1
    @nanny It will. This issue had been reported and fixed ~6 weeks ago. – Dmitry Dec 15 '14 at 18:55
1

As pointed out by @Dmitry, it was a bug. With version 0.8.8 from Elpa it works as expected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.