0

I have a weird problem where my emacs setup is extremely slow (as in takes a long time to show typed characters) when my laptop is running on battery. Once I connect it to power, the speed is normal.

I figure that the operating system (Ubuntu 18.04.3 LTS) is probably limiting the performance of my laptop (Thinkpad) to save battery. But I don't know which limitation is slowing down emacs and how to disable it (a laptop with a slow emacs is worse for me that a laptop with zero power).

Any help is appreciated.

  • Install the powertop utility and go to the Tunables pane and see autosuspend has been enabled for your keyboard device. – stsquad Dec 4 '19 at 17:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.