0

My Spacemacs share the same configuration on local macOS and remote Linux, but they look quite different.

The only OS related settings that I found in my configuration is that I enabled OSX layer on both. But I figured Spacemacs should be smart enough to do no harm on Linux even with this layer on.

Local: enter image description here

SSH: enter image description here

Things are not right in SSH:

  1. Menu Bar is missing.
  2. Line numbers are missing even though, as you can see, line-number-mode is on.
  3. Some tofu() glyphs are shown on Mode Line.
  4. Colors are slightly different.

What could be the cause? How do I fix them?

  • i don't know the ins and outs of how ssh works, but my guess is that the differences you are seeing are related to the terminal emulation provided by ssh? you may be able to get the menu bar with the -t option for ssh, and that might help with line numbers/colors too. not sure about the unicode characters. But you may prefer just using your local Emacs and TRAMP to edit files on the remote machine? You may not need to manually ssh and start emacs on your remote at all. – shoshin Dec 3 at 4:28
  • I'm not sure how to use -t option. But I can turn on menu bar manually with menu-bar-mode. However, that doesn't help the line number or color issues. I need to log in remote machine to do something more than just text editing, I guess TRAMP is not the best option for me. – an0 Dec 3 at 16:26
  • just ssh -t login@your.server might help? – shoshin Dec 3 at 16:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.