0

I'm using Emacs installed from the emacs-plus package from homebrew on Mac OS X 10.14.6. I uninstall/reinstall the package today and suddenly it stops working properly. The version of emacs-plus package and my configs are unchanged but some dependency packages may have through homebrew upgrade.

I have the following in the ~/.bash_profile:

export ALTERNATE_EDITOR=""
alias e="(/usr/local/Cellar/emacs-plus/26.3/bin/emacsclient -c &> /dev/null &)"

When I run e in the terminal, no GUI window starts up anymore. However, I have two Emacs and one emacsclient processes running. If I run e again, it spawns another two server and one client processes.

If I run /usr/local/Cellar/emacs-plus/26.3/bin/emacs -Q, an Emacs server process with a GUI window starts up (and no emacsclient) as expected.

If I run /usr/local/Cellar/emacs-plus/26.3/bin/emacsclient -c, the following returns:

/usr/local/Cellar/emacs-plus/26.3/bin/emacsclient: can't find socket; have you started the server?
To start the server in Emacs, type "M-x server-start".
Need to (re)build the epdfinfo program, do it now ? (y or n) Need to (re)build the epdfinfo program, do it now ? (y or n)

epdfinfo package is used by the pdf-tools in Emacs, and I guess it needs rebuild because I uninstalled them with Emacs earlier.

It seems like two server processes start and somehow they hang the client process.

Any suggestion what's going on here? How should I diagnose this further to fix it?

  • were you using homebrew to start the emacs server as a background service? I'm not on a mac currently but i remember that being an option when installing emacs from homebrew. I would at least try a ps aux | grep emacs and see how many processes are running. – shoshin Dec 3 at 3:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.