0

I've been using magit for a couple of weeks now and I really really like it. There is, however, one thing I still can't get to work, which is the highlighting of changes. In the pictures used in the walkthrough on Magit's website, changes are highlighted. Not so in my case. This is what a typical change looks like on my machine, using the Zenburn theme, but other themes are doing the same thing.

Picture 1: changes are not highlighted in magit using the zenburn theme

After the response I got from tarsius I checked if I had the magit-diff-refine-hunk variable set to "all", which was the case

enter image description here

I then checked if anything had changed, but at first sight nothing had.

enter image description here

But then I noticed something. If I selected the line with the changes, I could actually see the magit makes some kind of distinctions, but one that is only visible when the line with the changes is selected, like so:

enter image description here

So the question now is: how to get these changes to be visible when nothing is selected?

Ideas, anyone?

All the best,

MPE

3

To turn on "word-granularity" or "fine" differences set the option magit-diff-refine-hunk documented in Diff Options.

The reason that doesn't seem to properly work for you probably is due to a regression in the theme you are using. If you have not updated zenburn in a long time, then you might be in luck and doing so does the trick. Related issues are https://github.com/bbatsov/zenburn-emacs/issues/334, https://github.com/bbatsov/zenburn-emacs/pull/317 and https://github.com/bbatsov/zenburn-emacs/pull/300.

  • Hi Tarsius, thanks for the suggestion, I updated my question! – MPE2016 Dec 4 '19 at 13:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.