0

Up until this afternoon, I was able to run org-open-at-point on something like

[[file:/Users/apc/Desktop/test%20paper.pdf]]

and open the file named "test paper.pdf" in my Desktop. But I'm no longer able to, at least not with my current set up. (The problem is not limited to that particular file, but it does seem to have something to do with the space on the file name---see below.)

If I run emacs -q and run org-open-at-point on that link, I am able to open it as usual. If I then open the *Messages* buffer, I see

Running open /Users/apc/Desktop/test\ paper.pdf

But if instead I run emacs -q --load with the path of a file containing only the following two lines:

(require 'package)
(package-initialize)

I cannot get things to work as they used to. If I try to run org-open-at-point on that same link, I get

user-error: No such file: /Users/apc/Desktop/test%20paper.pdf

The problem seems to be caused by the space in the name of the file. Running org-open-at-point on

[[file:/Users/apc/Desktop/test.pdf]]

opens test.pdf as expected.

In case this matters: replacing %20 with \ doesn't help. Running org-at-point over

[[file:/Users/apc/test\ paper.pdf]]

yields

user-error: No such file: /Users/apc/Desktop/test\ paper.pdf

And just to double check, running dired on ~/Desktop does show the files I'm trying to open:

  /Users/apc/Desktop:
  total used in directory 304 available 9223372036852159103
  drwx------@  8 apc  staff    256 Dec 12 22:25 .
  drwxr-xr-x+ 70 apc  staff   2240 Dec 12 22:22 ..
  -rw-r--r--@  1 apc  staff   6148 Dec 12 22:00 .DS_Store
  -rw-r--r--   1 apc  staff      0 Sep 26 14:02 .localized
  -rw-r--r--@  1 apc  staff  67523 Dec 11 09:24 test paper.pdf
  -rw-r--r--   1 apc  staff     71 Dec 12 22:24 test.org
  -rw-r--r--   1 apc  staff     80 Dec 12 22:09 test.org~
  -rw-r--r--@  1 apc  staff  67523 Dec 12 22:08 test.pdf

I'm running Emacs 26.3, installed from https://emacsformacosx.com, on macOS 10.14.6. I haven't recently updated neither Emacs nor macOS.

Update: In case anyone else is running with issues opening links and runs into this: the problem is that there's been a change in the escape link syntax in the latest stable version of org-mode. See here.

| improve this question | | | | |
  • 1
    (package-initialize) goes through all installed packages, adjusts load-path and runs their auto-loads files. So maybe one of your installed packages is doing funny stuff in its auto-loads file? – jue Dec 13 '19 at 13:48
  • Thanks, that answers my question. If you post it as an answer I'll accept it. For the record, the problem is caused by the latest version of org (9.3) which changes the link escaping syntax. See the changelog. – apc Dec 13 '19 at 14:19
  • Glad I could help. However I have no idea which actual line in a autoloads file could cause this. So I leave this question open to someone who can really explain the root cause. – jue Dec 13 '19 at 14:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.