4

If I start emacs from the terminal, emacs will start up with a warning on the terminal:

Warning: Cannot convert string "-*-courier-medium-r-*-*-*-120-*-*-*-*-iso8859-*" to type FontStruct

I tried starting emacs with emacs -q. The warning was still there.

How to solve this problem? Thank you.

(My OS is Xubuntu 14.04.1. Emacs version is 24.4.1.)

  • 2
    I guess the solution described on ubuntuforums may help you – Iqbal Ansari Dec 16 '14 at 16:13
  • @IqbalAnsari Thank you. I solved the problem with the link you posted. Would you like to write that down as an answer to this question? Maybe it will help somebody else with the same problem. – Ben Dec 18 '14 at 15:06
4

A possible solution is posted on ubuntuforums. I am posting the answer. The link suggests adding the following to ~/.Xdefaults

emacs*font: 7x14

and running the command

xrdb -merge ~/.Xdefaults

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.