1

My emacs terminal is currently displaying ;0user@Ubuntu: ~user@Ubuntu:~$". This happened after my friend was using my laptop, and is persisting after uninstalling and reinstalling emacs, as well as deleting .emacs related files. I have tested the terminal on emacs on different accounts on my laptop, and it is not suffering from this, so migrating my files is an option, but annoying. Does anyone have a way of fixing the terminal on emacs? I'm running Ubuntu as well.

| improve this question | | | | |
  • 1
    Some kind of issue with your PS1 shell prompt, by the looks of it. What does echo $PS1 tell you (from a shell in that terminal) ? – phils Dec 19 '19 at 2:52
  • Thank you, it was the PS1 value, I'm not sure how the value was differing between bash on Emacs and bash on a normal shell prompt, they were both pointing to the same location for the shell – Andrew Dec 21 '19 at 0:12
  • You'd have to check your shell init file(s) to see what was setting it, and whether it was conditional on anything. If you can't figure it out, update the question with the relevant details. – phils Dec 21 '19 at 0:24
1

The problem ended up being in my .bashrc file in my home directory. The issue was the PS1 value under the case "$TERM" in clause had somehow been modified. I changed this value to PS1='${debian_chroot:+($debian_chroot)}\u@\h:\w\$ ' to reset it back to the default.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.