0

enter image description here

I use Emacs GUI in Ubuntu, when I use Emacs to open a easycrypt file, for example a.ec, Emacs will show a loading message at the bottom of the window, I guess it is in the minibuffer, but I am not sure. Could you please let me kown how to disable or modify this message? I have already enter image description heredisabled message buffer, and put

(setq inhibit-startup-screen t
      initial-buffer-choice  nil)

(setq inhibit-startup-message t) 

(setq inhibit-startup-message t)

in my ~/.emacs file, but the message still there when I open .ec files.

  • When I type M-x describe-function aka C-h f and look-up load, I see a *Help* buffer that states (in part): (load FILE &optional NOERROR NOMESSAGE NOSUFFIX MUST-SUFFIX) To the extent that you are using the function load, the second optional argument is NOMESSAGE. E.g., (load "/path/to/file" 'noerror 'nomessage) I would suggest trying to find out where you are loading easycrypt.el in your startup and see if you can modify the call to load as indicated in this comment. – lawlist Dec 23 '19 at 7:01
  • ** How do I disable the splash screen? Choose Proof-General > Customize Options and disable "Proof Splash Enable" (at the bottom) and choose "Save for Future Sessions" by clicking on the state button. Alternatively, put this in your configuration file: – pool liver Dec 23 '19 at 9:39
  • I use this to change the setting of my proofgeneral, and It works. – pool liver Dec 23 '19 at 9:45
  • It's not the minibuffer, it's the echo area (but the minibuffer is indeed itself displayed in the echo area). See section 1.2 of the manual for more info. – JeanPierre Dec 23 '19 at 14:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.