7

My config is a literate org-mode file.

On my Linux machine, the code blocks are highlighted with the relevant syntax highlighting (i.e. Elisp).

But on my Mac, I get this error when I load the buffer:

org-mode fontification error

How do I fontify the code blocks, and avoid that error?

0

I've had this problem when using a version of org, such as the one shipped with the latest version of emacs, that conflicted with the latest version of other packages (ESS, in particular). After updating to the latest version, the problem disappeared.

You will need to clear the pre-installed org from emacs after updating.

  • I am having this same problem. How do I 'clear' the pre-installed org in emacs? – Kaushal Modi Jan 18 '15 at 17:48
  • Delete it from the lisp src directory in the emacs installation. Where this is will depend on your OS, method of installation, etc. – user2619203 Jan 19 '15 at 20:43
  • Thanks. I tried that but it didn't help. – Kaushal Modi Jan 19 '15 at 21:10
  • I was able to resolve this just by installing org through package-list-packages; I didn't need to muck with the emacs build at all. I'm not familiar with the semantics of load-path, but it seems to prefer elpa to emacs builtins. I did install it through the org repository, at (add-to-list 'package-archives '("org" . "http://orgmode.org/elpa/") t), but I think the gnu repository will also work just fine since they seem to have the same version. – cosmicexplorer Jul 2 '15 at 11:13
  • This seems to not have solved the issue. Both the pre-installed version and the newest version induced the error. – xji Sep 3 '15 at 10:25
0

Another solution: I noticed that my value for org-plantuml-jar-path was incorrect. After fixing it to be an absolute path, everything was fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.