2

I've just switched to using spacemacs with powerline. I'm trying to make the font larger (my eyes are not as good as they used to be). But when I do, the powerline separator gets screwed up. Is there anyway to scale that up as well?

I've update size to 16 (from 13) and changed powerline-scale to 0.8 (from 1.1) to try and counteract the size problem.

dotspacemacs-default-font '("Source Code Pro"
                               :size 16
                               :weight normal
                               :width normal
                               :powerline-scale 0.8)

This is what I get enter image description here

1 Answer 1

1

Okay, I misunderstood how the :powerline-scale parameter works. To use with a larger font, I need to make it larger rather then smaller. For my situation, I scale factor of 1.5 seems to fix the issue.

dotspacemacs-default-font '("Source Code Pro"
                               :size 16
                               :weight normal
                               :width normal
                               :powerline-scale 1.5)
1
  • thanks for posting this, it helped me, for some reason when I download spacemacs on Lubuntu, I have a "gui" and "shell" emacs application I can choose from and the "shell" one was giving me a really screwy powerline but the font was larger by default. Apr 9, 2020 at 14:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.