1

I work mainly with javascript and typescript. And I have enabled lsp-mode in Doom Emacs. But I am not very happy about the descriptions and information shown to me on hover. It is not very useful and its spread out in opposite corners of the window.

take this example when I hover over .get() - emacs vs vscode. on hover in emacs on hover vscode

VSCode show me that the parameters is of type <P ResBody, ReqBody> whereas Emacs give me <ParamsDictionary, any, any>

In Emacs I have "to go definition" to get that more precise/accurate information. enter image description here

I don't really understand what controls this behaviour, lsp-ui or something else? If someone have some good information or link on how to make this in my eyes slight more useful.

Thanks

3
  • Do you see the same problem with eglot? – Stefan Jan 7 '20 at 13:49
  • lsp-ui is configured in ~/.emacs.d/modules/tools/lsp/config.el and in use-package! lsp-ui function, under :config section, it is stated: lsp-ui-doc-enable nil and is followed by some explanations - seems to be a small bug around. – Ian Jan 7 '20 at 15:15
  • @Stefan I have not tried with eglot. I have enough problems with the packages as is :D – kresdjan Jan 7 '20 at 15:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.