1

I have a working Owncloud server, and I would like to use Org Mobile to sync my Org files with my phone.

Following "Setting up the staging area" in the info doc for Org Mobile, I have customized the variable org-mobile-directory to the directory where I want my files to be stored on the server. I have now the following in my ~/.emacs:

 '(org-mobile-directory
   "/davs:MyUserName@MyIPaddress:/owncloud/remote.php/webdav/MyRemotePath/")

This syntax for the remote directory is what I understood from the TRAMP info docs.

When I run org-mobile-push, then after an expected message showing me the good certificate for my cloud and asking me if I am sure to connect, I always get "Variable 'org-mobile-directory' must point to an existing directory".

Is the syntax I am using correct? Am I missing something?

Notes:

  • The path /owncloud/remote.php/webdav/ is what I read in the settings of my Owncloud to specify the WebDAV address to applications.
  • I have verified that MyRemotePath exists on my server.
  • I have set org-mobile-files and I have verified that org-directory is set to an existing directory (if it matters, although the latter should only concern the pulling from the staging area).
  • I eventually would like to use Mobileorg. I have managed to sync from the Mobileorg application to my Owncloud, but apparently I would need a file index.org in my server directory in order to sync from the server to the phone. And this file seems to be generated by org-mobile-push, which is what led me to this problem.
  • The doc string for org-mobile-directory just says "The WebDAV directory where the interaction with the mobile takes place." So try pointing it to a directory only, i.e. no login name. Perhaps start with the bit after webdav - you might have to play about with it. – user16762 Jan 8 at 10:13
  • Thanks for the reply; what do you mean exactly by "no login name"? Mounting the remote directory to my system? (eventually I would like to do it without having to mount anything). And also, what do you mean by "start with the bit after webdav"? – Giuseppe Jan 8 at 18:07
  • Modify "/davs:MyUserName@MyIPaddress:/owncloud/remote.php/webdav/MyRemotePath/". You could try "MyRemotePath" or "webdav/MyRemotePath" etc. etc. You've nothing to lose. Personally, I use cadaver for webdav. – user16762 Jan 10 at 12:37
  • @m43cap I had already tried such variations, with no improvement. Any other suggestions? Could it be a certificate problem? – Giuseppe Jan 12 at 19:53
  • Maybe. Are you able ping it? Maybe try with a server you know already works. – user16762 Jan 14 at 6:22
1

The recent Tramp versions support the nextcloud method, which is also good for OwnCloud servers. You might have better Tramp support if you use the latest Tramp (via GNU ELPA), create on your local machine a NextCloud GNOME Account, and try it.

If there are further problems on the Tramp side, I might be able to help; I have configured several OwnCloud and NextCloud servers via Tramp already.

| improve this answer | |
  • Thanks for your post! I am actually planning to migrate to Nextcloud in the following days, so I will try the latest Tramp when this is done. If it works I will mark your answer as the solution; otherwise I will let you know :). – Giuseppe Jan 20 at 15:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.