0

I am trying to install emacs 26.3. In installed

sudo apt install autoconf make gcc texinfo libgtk-3-dev libxpm-dev libjpeg-dev libgif-dev libtiff5-dev libgnutls-dev libncurses5-dev

It cant find libgnutls-dev. I skipped that and did ./configure --with-gnutls=no and when I do make

make[2]: Leaving directory '/home/itsy/Downloads/emacs-26.3/admin/unidata'
  CCLD     temacs
/usr/lib/gcc/x86_64-linux-gnu/7/../../../x86_64-linux-gnu/libSM.so: undefined reference to `uuid_unparse_lower@UUID_1.0'
/usr/lib/gcc/x86_64-linux-gnu/7/../../../x86_64-linux-gnu/libSM.so: undefined reference to `uuid_generate@UUID_1.0'

Is there something I need to install ?

  • Which Linux distro (and which version) do you use? – Philopolis Jan 24 at 7:38
  • 1
    apt build-dep emacs should install all the required stuff for you – rpluim Jan 24 at 7:47
  • @rpluim I tried that. It says everything is installed. – velcro12 Jan 24 at 18:53
  • @Philopolis I am on UBuntu 18.04 – velcro12 Jan 24 at 18:53
  • So you’re trying to build emacs 26 (ie the current version) against headers and libraries provided by your 2 year old OS. Maybe this needs a newer version of libSM or its headers? I don’t have a better idea. – Dan Robertson Jan 24 at 22:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.