0

When I start entering a command and pause, this helpful window pops up at the bottom:

enter image description here

When I don't pause, it doesn't show up.

But sometimes, it takes more time to complete a command that I know, e.g. if it requires me to access modifier keys like shift or control.

In those cases, this window briefly flashes and disappears, often also freezing up the editor for about half a second or so.

How can I increase this pause time so I'm only shown the command completions if the pause is longer than, say 2 seconds?

0

What are you using for showing command completions? That looks a like which-key. If that's the case, I think you should modify which-key-idle-delay:

Delay (in seconds) for which-key buffer to popup. This
 variable should be set before activating which-key-mode.

A value of zero might lead to issues, so a non-zero value is
recommended
(see https://github.com/justbur/emacs-which-key/issues/134).

You may need to disable and re-enable which-key-mode to see the change take effect.

| improve this answer | |
  • I haven't installed anything myself, it's whatever that comes with spacemacs. I'll verify if I indeed am using which-key. – Peeyush Kushwaha Jan 27 at 16:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.