1

Since upgrading my mac to Catalina yesterday, I managed to get Emacs working again after allowing Ruby access to all files in the settings, and most of it works fine, but I can't get Magit to recognise the repo that it is in. C-x g simply does not work, so I tried M-x magit-status in the minibuffer and it asks if I want to create a repo, but I'm already in the the right place, still working on the same things I was working on last week. The only change is the Mac OSX upgrade (work machine so enforced).

  • 1
    very silly question, but you did have a project file open when you "M-: magit-status" ? – RichieHH Feb 3 at 14:12
  • 1
    Not a silly question actually, but I am definitely inside my project as was trying to commit. I've just installed xcode in case that was the issue, but still nothing. I can use git in terminal, but magit is not connecting – iFunction Feb 3 at 14:19
  • 1
    check out the value of magit-repository-directories to be sure thats not an issue. (C-h v magit-repository-directories) – RichieHH Feb 3 at 14:26
  • 1
    and it should continue to do so. nil means using current directory afaik. – RichieHH Feb 3 at 14:48
  • 1
    make 100% sure the file you have open is in the git repo hierarchy and not some copy elsewhere... – RichieHH Feb 3 at 14:49
3

SOLVED: thanks to all who commented here it helped me find a solution. So first thing to do with Catalina is to give full file access to emacs, this is done in settings - Security & Privacy - /Full Disk Access. Then install this at the start of your settings: https://github.com/purcell/exec-path-from-shell. Apparently this is a common mac issue, but I've not had it till now and it is actually a FAQ in the Magit docs which is where I got the Purcell package tip from.

| improve this answer | |
  • 2
    don't forget to mark your solution as the Answer. – RichieHH Feb 3 at 15:59
  • I have to wait 2 days – iFunction Feb 3 at 19:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.