3

I am trying to open a file that contains the following utf-8 character: ⛺
Unfortunately, my emacs does really not appreciate, and immediately crashes.
I have tried to comment out all my init.el (and actually I've even renamed my .emacs_d folder to be sure that my local packages/functions have nothing to do with it).
The crash still occurs (it just closes the editor when attempting to open the file).

Any idea of what the problem might be/how to fix this ?
Using emacs 25.2.2 on Ubuntu 18.04.

Edit: here is the terminal output when running emacs -Q --debug-init.
No message on startup.
When trying to paste ⛺ in the scratch buffer:

X protocol error: BadLength (poly request too large or internal Xlib length error) on protocol request 139
When compiled with GTK, Emacs cannot recover from X disconnects.
This is a GTK bug: https://bugzilla.gnome.org/show_bug.cgi?id=85715
For details, see etc/PROBLEMS.
Fatal error 6: Aborted
...  // long backtrace ending with a core dump
4
  • 1
    Just an FYI, you can start emacs without init file by invoking the command emacs -Q. Adding --debug-init starts emacs in debug mode
    – Swedgin
    Feb 10 '20 at 16:12
  • Thanks, I did not know about the debug mode (and about the -Q). I'll add the error message to my message.
    – m.raynal
    Feb 10 '20 at 16:15
  • 2
    This is the infamous Xft + emoji bug. Either upgrade to emacs-27, or to an emacs-26 build compiled with Cairo support.
    – rpluim
    Feb 11 '20 at 8:30
  • I get the same behavior (i.e. emacs crashes) when inserting certain unicode characters. In my case, some of the command line tools that I'm using output empty circles (○) and filled circles (⏺) for checked and unchecked options, respectively. I did manage to crash Emacs for other types of circles, while using counsel-unicode-char. I'm using emacs 26.1 on Debian.
    – mihai
    Jun 3 at 7:44
2

I see the same crash. Quoting the likely-looking answer from @rpluim:

This is the infamous Xft + emoji bug. Either upgrade to emacs-27, or to an emacs-26 build compiled with Cairo support. – rpluim

As discussed at #30045 - Emoji causing Emacs (GTK+3 backend) to crash - GNU bug report logs and Modifying Frontsets, a quick workaround is to disable the problematic font for colored emoji via M-:

(add-to-list 'face-ignored-fonts "Noto Color Emoji")

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.