0

I read in the manual, and here that

#+STARTUP: overview
#+TASKS: nil

* TODO Config tasks                                                :tasklist:
** TODO todo1
   SCHEDULED: <2020-02-16 Sun>
** TODO todo2
   SCHEDULED: <2020-02-17 Mon>
   :LOGBOOK:
   - State "TODO"       from              [2020-02-13 Thu 01:26]
   - State "TODO"       from              [2020-02-13 Thu 01:26]
   :END:

#+tasks: nil should stop the exporting of todo items. It doesn't using the md backend. What am I doing wrong?

My org export config is as follows:-

** Self documenting config file
   #+begin_src emacs-lisp

    (use-package ox-gfm
      :defer 3 
      :after org
      :config 
      (defun config-export-to-markdown()
        (interactive)
        (if (and (eq major-mode 'org-mode) (file-exists-p (concat (file-name-sans-extension (buffer-file-name)) ".md")))
            (org-gfm-export-to-markdown)))

      (add-hook 'after-save-hook 'config-export-to-markdown))

   #+end_src
1

Further googling revealed I needed this format. I don't know I'd have got that from the docs.

#+OPTIONS: tasks:nil

As a sidenote, org-inlinetask was what I really wanted too. Very handy.

| improve this answer | |
0

The correct option to exclude task keywords is the following:

#+OPTIONS: todo:nil

See all export options here: https://orgmode.org/manual/Export-Settings.html

| improve this answer | |
New contributor
Perdu is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.