0

I have syntax-checking in my layers, and according to the documentation, it should be enabled by default in every buffer. However, for me this is not the case. How do I enable flyspell syntax-checking by default in spacemacs?

3
  • Your code to enable flycheck in all modes? Have you added (global-flycheck-mode) to your emacs config?
    – RichieHH
    Feb 17, 2020 at 0:20
  • Yeah, that doesn't work. Even doing M-x global-flycheck-mode disables correctly but doesn't enable. Feb 17, 2020 at 14:35
  • (global-flycheck-mode 1) to avoid any confusion.
    – RichieHH
    Feb 17, 2020 at 15:51

1 Answer 1

0

M-x customize-variable RET global-flycheck-mode and set to non-nil.

M-x customize-variable RET flycheck-global-modes and set to all.

Make sure you hit Apply and Save.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.