1

I am using org-mode TODO tracking change (in-buffer settings) and I'm having some issues. All the info is taken from the official docs (https://orgmode.org/manual/Tracking-TODO-state-changes.html)

I have added the buffer setting line at the top:

#+TODO: TODO(t) BUG(b) WAIT(w@/!)| DONE(d@/!) CANCELLED(c@/!)

and it's working, except two features I would like to have:

  1. When changing to the WAIT state, it won't ask me for a note and the timestamp is not recorded either.
  2. The DONE state is not grayed out as it's the case with CANCELED, despite both being specified after the "|" pipeline character.

I have not tested the same setting in a global init.el config because I need this setting different for each file.

enter image description here

1

By the time I posted my question I have manage to find the culprit. Posting it with an answer just in case others need to see this.

The setting line was missing a space after the WAIT state and the "|" pipeline, which caused both issues.

Correct syntax:

#+TODO: TODO(t) BUG(b) WAIT(w@/!) | DONE(d@/!) CANCELLED(c@/!)
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.