0

I opened a serial-term to /dev/ttyUSB0. I can't quit it. C-x k results in the following message:

term-quit-subjob: Process /dev/ttyUSB0 is not a subprocess

1

You should be able to kill the buffer with C-c k.

General: all C-x keys should work, if you use C-c instead. So to change to another window would be C-c o instead of C-x o.

Edit C-c <letter> is often used for user keybindings, therefore you maybe might need to unbound your user keybinding before this works.

3
  • I stated in the question that this doesn't work. Perhaps it's a bug. I'll try it with emacs -q to test. – Harvey Mar 1 '20 at 20:55
  • You only stated, that it is not working with C-x k this is different, becuase you should use C-c k instead. my solution is working on my setup (but I have to unbound my private setting of C-c k before) – jue Mar 2 '20 at 13:04
  • C-c k runs (kill-buffer) in term's char mode, same as C-x k does in line mode. The output in the question is from kill-buffer. But since asking, I've updated my dot files and now it works. :¯_(ツ)_/¯ – Harvey Mar 2 '20 at 17:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.