Upon startup of my emacs 24.3, I'm getting the errors:

Warning (emacs): Unable to activate package `with-editor'.
Required package `emacs-24.4' is unavailable

I have a dim recollection that when I first started this job, I sometimes used another machine that had 24.4, and with-editor may have been some package used by the coworker (since left) who had a more advanced emacs version in their home directory and who had suggested I copy some of their configuration.

However, if I grep my .emacs, .emacs.d recursively, or my .emacsinit, I don't see with-editor.

Running emacs -Q doesn't have the error.

What is causing it, and to the extent stackoverflow lets me ask, what techniques could I be using to troubleshoot this myself?

1 Answer 1


The command grep with-editor ~/.emacs.d/*/*/* found a directory called elpa with a subdirectory with-editor-2.8.1. Many other files under elpa outside of that directory had references to with-editor. Simply deleting all of elpa did away with this error, allowing emacs to actually start.

The command find ~/.emacs.d -name '*with-editor*' would also have found the with-editor package, but wouldn't have let me see immediately that lots of other things under elpa depended on it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.