4

I am used to my tables aligning nicely when I hit C-c C-c in Linux. In Emacs for OS X (emacsforosx.com) this does not behave on my system.

enter image description here

It works in Aquamacs.

  • 2
    Select a monospaced font please with M-x set-default-font, that should resolve it. – wasamasa Dec 20 '14 at 16:42
  • Agree that the problem is that you're using a non-monospaced font. @wasamasa: could you convert your comment to an answer, adding a little more detail to flesh it out? – Dan Dec 20 '14 at 16:52
  • Very well, done. – wasamasa Dec 20 '14 at 17:16
10

While org-mode is a very flexible tool, it has some very hardcoded limitations in its core functionality. The one you're encountering is the reliance on a monospaced font (such as Andale Mono, Monaco or Menlo to name a few ones your OS X system should come with) to display tables in an aligned fashion.

There are multiple options how you can solve it. If you are already relying on monospaced fonts, set Emacs' default font in your init file to a monospaced one:

(setq default-frame-alist '((font . "Monaco-12")))

Alternatively, customize the org-table face with M-x customize-face RET org-table RET to use a monospaced font to make only org-mode tables display correctly.

  • Thanks! I suspected that was the issue, but I apparently did something wrong when I tried to switch to Inconsolata to correct it. – anr78 Dec 20 '14 at 20:15
1

I was having the same issue in the OS X Emacs 24 window-system. My default font is variable width, so naturally my Org-tables were not aligning properly. To continue with @wasamasa's solution for customizing the font for just the org-table mode and keeping a default variable width font for everything else, I found this solution helpful: `variable-pitch` for org-mode, fixed-pitch for tables?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.