0

I'm newbie to emacs/spacemacs. I'm using emacs version 26.3

I have installed spacemaces in my system using command git clone https://github.com/syl20bnr/spacemacs ~/.emacs.d and rm ~/.emacs

Now I'm trying to setup my C++ IDE on my spacemacs editor using this link.

Also, I've installed eglot package and added below to ~/.emacs.d/init.el

(require 'eglot)
(add-to-list 'eglot-server-programs '((c++-mode c-mode) "clangd"))
(add-hook 'c-mode-hook 'eglot-ensure)
(add-hook 'c++-mode-hook 'eglot-ensure)

I restated the emacs editor. Now I'm expecting spacemacs to do the code completion for me but it is not working

clang version in my system -

$ clangd --version
clangd version 7.0.1 (tags/RELEASE_701/final 349238)

my system information are -

    $ lsb_release -a
    LSB Version:    core-2.0-noarch:core-3.2-noarch:core-4.0-noarch:core-2.0-x86_64:core-3.2-x86_64:core-4.0-x86_64:desktop-4.0-amd64:desktop-4.0-noarch:graphics-2.0-amd64:graphics-2.0-noarch:graphics-3.2-amd64:graphics-3.2-noarch:graphics-4.0-amd64:graphics-4.0-noarch
    Distributor ID: openSUSE
    Description:    openSUSE Leap 15.1
    Release:        15.1
    Codename:       n/a

I'm getting below error during emacs startup File is missing: Cannot open load file, No usch file or directory

enter image description here

How to solve this issue?

  • How did you install eglot? Examine your emacs load-path and ensure it can find eglot. C-h v load-path. I dont know spacemacs but look into using melpa installs if its supported. melpa.org/#/getting-started – RichieHH Mar 8 '20 at 9:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.