1
$ sudo apt install eclipse eclipse-jdt 

Then, tried to install eclim using use-package in Emacs:

(use-package eclim
  :ensure t
  :config
   (require 'eclim)
   (setq eclimd-autostart t)
   (defun my-java-mode-hook ()
   (eclim-mode t))
   (add-hook 'java-mode-hook 'my-java-mode-hook))

It seems, it did not install it. Then, I used terminal:

downloaded:

eclim_2.8.0.bin

debian# cd Downloads

debian# ./eclim_2.8.0.bin

Welcome to the installer for eclim 2.8.0. Please specify the root directory of your eclipse install. Ex: /opt/eclipse /usr/local/eclipse

> /home/tom/.eclipse/

The eclipse launcher/executable could not be found in that directory

eclipse is installed in ~/.eclipse

Also, how to configure executable directory path, using use-package in Emacs?

4
  • See this: github.com/emacs-eclim/emacs-eclim - configure/modify custom-set-variables ... – Ian Mar 12 '20 at 14:08
  • Ian: I followed that link for installation... but unable to resolve – tom_kp Mar 12 '20 at 14:23
  • Try this: (setenv "PATH" (concat "/home/tom/.eclipse:" (getenv "PATH"))) (add-to-list 'exec-path "/home/tom/.eclipse") before (use-package eclim...) – Ian Mar 12 '20 at 14:33
  • Ian: I tried, but that also did not work. – tom_kp Mar 12 '20 at 14:54
0

Thank you Ian.

  1. I manually downloaded the eclipse file directly from the site, eclipse.org. Then, installed it using GUI.

  2. Then, manually downloaded the eclim file from the site, eclim.org. Then, I could give the path

/home/tom/eclipse/jee-2019-12/eclipse/

  1. Also, installed emacs-eclim by cloning the git.

Now, the eclimd is not starting. I will post the question separately,

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.