I know there is already a post asking this, but the author is using Emacs 26.3 and for what I've read starting with Emacs 27 there is now proper support for ligatures, but they should be enabled in some way (?)

I'm on Emacs 28 now, and I'd like to know the steps to obtain proper ligatures for my font.

Btw I use Arch

  • 1
    What have you tried? Is the other solution working for you? Which part don't you like about it? And please point to "what I've read". – Stefan Mar 22 '20 at 14:19
  • I've not tried anything because I don't know where to start. I found a guide for another font but nothing for JetBrains Mono – Francesco Noacco Mar 23 '20 at 15:34
  • The link in your question describes two ways to enable ligatures for JetBrains Mono. Have you tried them? Note that neither should require anything newer than emacs-26 – rpluim Mar 24 '20 at 8:33
  • I linked to a specific answer because with emacs 27 there now is native support for ligatures without using prettify-symbols and the like. My question is how to enable them. – Francesco Noacco Mar 25 '20 at 9:37

I think you misunderstand what's been included in Emacs 27. Emacs 27 includes a new font backend based on the HarfBuzz library. The front end bits still need to be worked on according to Eli Zaretskii in this reddit post

I'm wondering if anyone is working on native support

It's already supported in Emacs 27, but someone should code the Lisp part of that: define the character sequences to be ligated, figure out when and how to enable which parts of them, etc.

Patches welcome.

  • But as I replied before there is already a way to do this with another font – Francesco Noacco Mar 26 '20 at 21:05

For Emacs 27.1 I had success with Mickey Petersen's ligature.el

The requirements are pretty specific, but the installation instructions worked without modification for JetBrains Mono

  • Thank you, I found some time ago a table for jetbrains mono and I just copied it over to my config – Francesco Noacco Nov 5 '20 at 14:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.