0

I've spacemacs installed in my ubuntu/opensuse OS

emacs version 26.3.

SPC shortcut is not working for my spacemacs.

I'm getting message Buffer is read-only: #<buffer *spacemacs*>

Below is the screenshot -

Buffer is read-only error message

How can I make SPC key work for my spacemacs?

0

Spacemacs by default has the SPC key as leader.

Double check this in the .spacemacs file (which is by default in home directory).

Check that the following line exists in the configuration.

dotspacemacs-leader-key "SPC"

If this does not work check for boot up errors.

Check *Messages* buffer to see if there are any errors while booting up.

One other thing I notice is that the powerline has a blue color in it. This blue color means you are in emacs mode. When you were setting it up for the first time you might have selected emacs keybinding. In this case just delete the .spacemacs file then reopen.

When it first opens it will ask you.

What is your perfered editing style?

Select the below option

Among the stars aboard the Evil flagship (vim)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.