0

I use emacs -nw + tmux. Just upgraded Magit from 2.8.0 to 2.90.1, and found it always open a new Emacs GUI window when committing instead of use current Emacs instance directly (the behavior in 2.8.0). I cannot find the option to customize this annoying behavior.

I'm not using emacsclient

2

This is not an intentional change in behavior and so there is no Custom option that would allow you to go back to the old behavior.

To clarify: the cause of the new and undesirable behavior that you are seeing is either a bug or misconfiguration on your end. Nobody would want that behavior. I did not implement that behavior. It just happens and everyone agrees that that is not good.

It is not possible to add an option to disable that undesirable behavior because it is unknown what is causing it. And even once it known what is causing the behavior it would not make sense to add an option, because then we could just fix the bug for everyone, instead adding an option to optionally do that.

In other words, something is wrong and you will have to figure out what it is. I recommend you start with emacs -Q... and the other debugging tools described in the manual.

| improve this answer | |
  • Is this possible to have an option to customize? My Emacs always spend >10 seconds to startup...... – kuanyui Apr 19 at 4:34
  • @kuanyui If you can reliably reproduce this working correctly when you use 2.8.0 and not working when you use 2.90.1, then you could use git bisect on the Magit source code, to track down the cause of the bug. – phils Apr 19 at 10:15
  • Yes, I just removed all magit & git related old packages via package.el, then install via git clone, now all seems work again! Thanks! – kuanyui Jun 18 at 13:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.