0

this is slightly embarrassing, but i'm confused about it so:

i run emacs 26.1, org 9.3.

when i use the org exporter to export a file to odt format, tramp fires up and runs on the newly created file. after the .odt is created, in messages i get a message like, "Tramp: Opening connection for file /path/to/new/file.odt" and i have a buffer (and tramp process?) named *tramp/archive file /path/to/new/file.odt*. the new odt file is 'mounted'. when i exit emacs, it first has to 'unmount' the file. it also shows up as a mounted 'drive' in my file manager. i find this very bizarre.

the only things in my init file about tramp are:

  • tramp-backup-directory-alist (set to a file path)

  • tramp-default-method (set to "ssh")

  • tramp-mode-hook auto-sudoedit

my only org-export conf in my init it:

  • require 'ox

  • require 'ox extra

  • ox-extras-activate '(ignore-headlines)

*

if this is too weird to help me troubleshoot: is there a way to just block/disable tramp? i very rarely use it, and use the odt exporter much more often.

  • M-x customize, tramp, Tramp mode, toggle to off disables it. – mooseface Mar 24 at 22:12
1

You are hit by the new tramp-archive.el package, which regards *.odt files as an archive (like *.tar files). In order to disable this, you might add the following to your ~/.emacs:

(with-eval-after-load 'tramp-archive
  (setq tramp-archive-enabled nil))

However, there might be an error in the org exporter, because tramp-archive is activated only for a file name xxx.odt/ (note the trailing slash). Maybe you report this to the org people.

| improve this answer | |
  • thanks for this. disabling it does work. but then i'm still wondering, what other functionality am i disabling? – mooseface Mar 25 at 19:03
  • Tramp file archives. Since you don't use them, you might not miss them :-) Tramp itself shall still be enabled. – Michael Albinus Mar 25 at 19:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.