3

Q: how do I suppress mu4e warnings about the update process?

I am using mu4e with mbsync. Recently, the latter has started to emit an error/warning message about losing track of messages. When it does so, mu4e spits out a warning message:

[mu4e] Update process returned with non-zero exit code

That's normally fine, but it is annoying, especially as it spams my echo area every time mu4e checks my email.

Until I figure out what the problem is with mbsync, I have to tolerate the "losing track of messages" warning it gives. However, I'd like to know how to tell mu4e to shut up about it so it doesn't continue to alert me about non-zero exit codes. How do I do that?

3

Much simpler than I realized: just set mu4e-index-update-error-warning to nil.

The docstring:

Whether to display warnings during the retrieval process.
This depends on the ‘mu4e-get-mail-command’ exit code.

Here's a little function to toggle the setting:

(defun mu4e-toggle-ignore-warnings ()
  "Toggle whether or not mu4e reports update process warnings to
echo area."
  (interactive)
  (setq mu4e-index-update-error-warning
        (not mu4e-index-update-error-warning)))
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.