1

When I ran GNOME, I used to be able to click on any link in Emacs, and it would open in my default web browser.

But now that I'm using i3, it doesn't work any more, even though I haven't changed any Emacs settings. I don't get any messages or errors—it just does nothing. I also tried M-x browse-url-at-point, while on a URL, but that doesn't work, either.

As far as I can tell, I have the appropriate settings: browse-url-browser-function is browse-url-generic, and browse-url-generic-program is set to qutebrowser, my default browser. So why can't I open URLs? And/or how can I debug this?

  • Please specify what you mean by "doesn't work". What happens, and what did you expect to happen instead? Can you give a recipe (starting with emacs -Q - no init file) to reproduce the problem? – Drew Mar 30 at 20:52
  • I already specified as much as I can: "I don't get any messages or errors—it just does nothing." What I expect to happen instead is what the function is meant to do. From the documentation: "Ask a WWW browser to load URL." – Jonathan Mar 30 at 20:54
  • Try M-x (executable-find "qutebrowser") RET. Does this show the path or does it just show nil? – Tobias Mar 30 at 22:18
  • It returns the correct path. – Jonathan Mar 30 at 23:08
2

This took me forever to figure out, but it turns out Spacemacs had cached a bunch of environment variables. One in particular, $XAUTHORITY, was making it so that qutebrowser wouldn't start. Manually editing my spacemacs env file and updating that variable fixed the problem.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.