0

I'm trying to send email from emacs-gnus. But still get this error:

smtpmail-send-it: Sending failed: 504 5.5.2 : Helo command rejected: need fully-qualified hostname

My config is:

(setq send-mail-function        'smtpmail-send-it
      message-send-mail-function    'smtpmail-send-it
      smtpmail-smtp-server      "smtp.zenbox.pl"
      smtpmail-smtp-service 587)

Then I found info that it can be configuration with postfix https://serverfault.com/questions/357990/smtp-auth-with-postfix-reject-with-error-need-fully-qualified-hostname but I haven't found this line "reject_non_fqdn_hostname" in my configuration. Is it problem with emacs conf or with postfix? How I can fix it?

1

"smtp.zenbox.pl" wants the machine from which you're sending mail to have a fully qualified domain name. You can arrange for that either by making sure that (system-name) returns one, or by setting smtpmail-local-domain to an appropriate value.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.