1

I've used emacs on Windows 10 for a year. Recently, my "box" cursor in emacs has become a thin vertical line.

I have tried setting the variable "cursor-type", but this no longer seems to have any effect.

I have found a short comment that emacs might be detecting assistive technology (like speech recognition) and using a system cursor. See here. I've tried turning off speech recognition in Windows, but that doesn't seem to fix the cursor in emacs.

Is there a way to force emacs to use a box cursor instead of a Windows native cursor? (If this is indeed my problem.)

  • Can you provide a recipe to reproduce the problem, starting with emacs -Q (no init file)? If not, bisect your init file to perhaps find the culprit. – Drew Apr 1 at 22:10
  • Even with emacs -Q, the cursor is a thin vertical line. I used to have a block cursor, but something has changed in how emacs and Windows interact. – Kevin Wright Apr 3 at 1:24
  • Maybe do M-x report-emacs-bug, to report it as a bug. Alternatively, you can copy the Emacs version and build info provided automatically for the bug report into your question here. (Or else copy what you see from M-: (emacs-version), C-h v emacs-build-system, C-h v emacs-repository-version, C-h v system-configuration-options, and C-h v system-configuration-features.) Perhaps such info will help someone answer the question. – Drew Apr 3 at 3:42
  • I guess you also made sure screen magnify is turned off? I see that too is mentioned in the post you cited. (Good find of that post, BTW.) – Drew Apr 3 at 3:44
1

Found the answer on stackoverflow.

;; Disable the system cursor caused by screen reader etc.
(setq w32-use-visible-system-caret nil)

Helps to know that you need to search for "caret" instead of "cursor".

| improve this answer | |
  • 1
    I checked your answer and it works. Perhaps accepting your answer? – Name Sep 7 at 11:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.