0

For the past few days I have been trying to get Emacs to update and display my PDF when I press C-c C-a, once saved. I save with C-x C-s.

But everything I have tried fails, including every other advice I've read. I have a fresh install of Doom Emacs and Emacs26. I've installed AucTex, PDF-Tools and Latex-Preview_Pane and none of them work. My current set up opens the external PDF viewer despite the code I have in my init:

;; Use pdf-tools to open PDF files
 (setq TeX-view-program-selection '((output-pdf "PDF Tools"))
  TeX-source-correlate-start-server t)

;; Update PDF buffers after successful LaTeX runs
    (add-hook 'TeX-after-compilation-finished-functions
       #'TeX-revert-document-buffer)

`

1
  • Please specify what doesn't work, and what you tried. Try to provide a step-by-step recipe to reproduce the problem, starting with emacs -Q (no init file), saying what happens at each important step and what you expected to happen instead. Thx. – Drew Apr 2 '20 at 15:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.