0

Hi I am a little bit confused, because I think that I have already managed to make ispell work on my macOS 10.15.4 and emacs 26.3, but when I tried it I got an error that emacs cannot find ispell.

Then I figured that I need to install it which I did with brew install ispell but now emacs responses with Can't open usr/local/Cellar/ispell/3.4.00/lib/ispell/en_US.hash when I run M-x ispell. When I looked into usr/local/Cellar/ispell/3.4.00/lib/ispell/ there was no en_US.hash only american.hash and english.hash

Just before this error emacs also tells Starting new Ispell process /usr/local/bin/ispell with en_US dictionary... for a very short time.

I guess that some variables are set wrong, but how can I fix this?

5
  • 1
    You can use M-x ispell-change-dictionary to look at the available dictionary names, and customize the ispell-dictionary user option to one of those values in order to set a default in Emacs.
    – phils
    Apr 2 '20 at 20:46
  • At a guess, the en_US default is probably coming from some system locale settings; but I don't know how you would go about changing those, nor whether than would be a good idea.
    – phils
    Apr 2 '20 at 20:49
  • Another option, of course, would be to install some system dictionary package which includes a en_US.hash file.
    – phils
    Apr 2 '20 at 20:49
  • @phils changing the directory with M-x ispell-change-dictionary worked. I am using doom emacs is this an issue for the default dictionary? running ispell from the terminal also worked fine... do you know which dictionary does the terminal use by default? Apr 2 '20 at 20:55
  • I could only guess that you have environment variable differences between your shell and Emacs. This seems pretty common with OSX which is why github.com/purcell/exec-path-from-shell is popular on that platform. I can't tell you what to look for specifically, but the environment (and the relevant ispell documentation) is where I'd start.
    – phils
    Apr 2 '20 at 21:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.