2

Here is my example mwe-1.tex

local variable declaration from within this file is

%%% Local Variables:
%%% mode: latex
%%% mode: orgtbl
%%% End:

when I execute this command in a shell:

emacs -q --eval '(load-library "org-table")' mwe-1.tex

The actual mode is latex but not orgtbl.

Did I miss something ?

3

Using mode for anything but the major mode is deprecated. To enable minor modes, use eval:

%%% Local Variables:
%%% mode: latex
%%% eval: (orgtbl-mode 1)
%%% End:

See (info "(emacs) Specifying File Variables").

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.