0

I am on a Raspberry Pi with Raspbian and any shortcut with Alt-Shift-arrow has no effect in emacs org-mode. I discovered it while trying to use org-shiftmetaleft and org-shiftmetaright.

This is my lsb_release -a

No LSB modules are available.
Distributor ID: Raspbian
Description:    Raspbian GNU/Linux 10 (buster)
Release:    10
Codename:   buster

and M-x emacs-version is

GNU Emacs 26.1 (build 2, arm-unknown-linux-gnueabihf, GTK+ Version 3.24.5) of 2019-09-23, modified by Debian

I tried to use xevto figure out, what happens when I press the keys but I don't understand what the output means:

FocusOut event, serial 48, synthetic NO, window 0x2c00001,mode NotifyGrab, detail NotifyAncestor FocusIn event, serial 48, synthetic NO, window 0x2c00001,mode NotifyUngrab, detail NotifyAncestor
KeymapNotify event, serial 48, synthetic NO, window 0x0,keys:  
2   0   0   0   0   0   4   0   1   0   0   0   0   0   0   0
0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0

I appreciate any ideas how to tackle this.

  • If you can reproduce the problem when starting with emacs -Q (no init file) then please consider reporting it as a bug or an enhancement request, using M-x report-emacs-bug. – Drew Apr 4 at 16:08
0

Apparently it's not an emacs problem. It seems the openbox window manager is intercepting the shortcut.

To disable this behavior I had to copy the system-shortcut-file, rename it and comment the S-A-arrow-shortcuts out.

 mkdir ~/.config/openbox
 cp /etc/xdg/openbox/LXDE/rc.xml ~/.config/openpox/lxde-pi-rc.xml

Then nano ~/.config/openpox/lxde-pi-rc.xml and comment the following lines out with <!-- ... --> or delete them.

<!--  
  <keybind key="S-A-Left">
    <action name="SendToDesktop"><to>left</to><wrap>no</wrap></action>
  </keybind>
  <keybind key="S-A-Right">
    <action name="SendToDesktop"><to>right</to><wrap>no</wrap></action>
  </keybind>
  <keybind key="S-A-Up">
    <action name="SendToDesktop"><to>up</to><wrap>no</wrap></action>
  </keybind>
  <keybind key="S-A-Down">
    <action name="SendToDesktop"><to>down</to><wrap>no</wrap></action>
  </keybind>
-->

After a system restart, M-S-right and M-S-left worked as expected in emacs org-mode. :-)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.