1

I am editing .s files whit an assembly-to-binary translator that does not accept ; as a comment delimiter but accept C like comments (namely // and /* ... */).

I tried to modify comment-start variable locally using set-variable command but it does not matches any comment-start. When I display the variable within a .s (emacs correctly indicate Assembler mode) it says ; locally and nil globaly (wtf ??).

For the asm-comment-char variable, it says value is 59 which corresponds to the ascii code for ; but when I tried to set it, for example to //, it says it does not match type character of the variable. So I tried to set it to 047047 which is supposed to be the ascii code for // but my comment's keys still give ; or ;;.

So what can i do ? Which one of these variables control the comments characters in assembly mode ?

1
  • 1
    asm-comment-char does and as you note, it's a single char. That's a limitation that should probably be lifted. I would suggest you consider submitting a bug report – NickD Apr 7 '20 at 15:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.