0

I have a directory ~/mail containing directories and Maildirs.

I was hoping I might read messages contained in it by evaluating

(setq gnus-select-method '(nnnil "")
      gnus-secondary-select-methods
      '((nnmaildir "private" (directory "~/mail"))))

and M-x gnus. But I see only an empty buffer. How do I find my messages?

1

Your select methods tell Gnus where to find your Maildir, but not which "groups" to subscribe to. See (gnus) Finding the News, one of the first sections of the Gnus manual:

First of all, you should know that there is a special buffer called
‘*Server*’ that lists all the servers Gnus knows about.  You can press
‘^’ from the Group buffer to see it.  In the Server buffer, you can
press ‘<RET>’ on a defined server to see all the groups it serves
(subscribed or not!).  You can also add or delete servers, edit a
foreign server’s definition, agentize or de-agentize a server, and do
many other neat things.  See Server Buffer.  See Foreign Groups.
See Agent Basics.

Though it's possible to subscribe to groups from the Group buffer, I find it easier to go through the Server buffer as described above.

So, from the Group buffer (the one that you're greeted by when you start Gnus) press ^ to get to the Server buffer. Once there, select the relevant Maildir server by pressing RET with point on it. Then you can subscribe to any number of groups by pressing u with point on them. See (gnus) Browse Foreign Server:

‘u’
     Unsubscribe to the current group, or, as will be the case here,
     subscribe to it (‘gnus-browse-unsubscribe-current-group’).  You can
     affect the way the new group is entered into the Group buffer using
     the variable ‘gnus-browse-subscribe-newsgroup-method’.  See *note
     Subscription Methods for available options.

Pressing q twice will exit the group browsing and Server buffers and you should be back in the Group buffer with your new group subscriptions visible.

| improve this answer | |
  • thanks! but after i press RET on something in the server buffer i see only an empty buffer. – Toothrot Apr 15 at 22:00
  • @Toothrot That means you haven't configured the nnmaildir select method correctly, and/or the Maildir is in a format that Gnus doesn't understand. – Basil Apr 15 at 22:11
  • @Toothrot Try setting gnus-verbose and gnus-verbose-backends to 10 in case anything interesting gets printed. – Basil Apr 15 at 22:17
  • thanks, it eventually worked. i suspect gnus only recognizes directories containing maildirs, not directories containing directories containing maildirs. – Toothrot Apr 16 at 9:46
  • @Toothrot Yes, I think that's right. Though you might be able to get something to work using some of nnmaildir's virtual server settings; I don't know and I haven't tried. See (gnus) Maildir. – Basil Apr 16 at 10:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.