I have installed a (doom) emacs to start developing with Ruby. So far I have mainly used Sublime Text but because of reasons I want to give emacs a chance.
I tried Spacemacs too but uninstalled this because it was really slow)

A problem I have now is that the minibuffer is constantly showing some errors because it can't access the ruby gem reek which some emacs package uses for code analyzing. I am using the asdf version manager but I have not found a way to tell emacs to use it as well. How can I do this?

  • 1
    How does asdf work? Does it use executable shims and modified PATH entries like rbenv? Then it might be enough to move its config to .profile (on Ubuntu, at least) and relogin.
    – Dmitry
    Apr 21, 2020 at 19:11

1 Answer 1


I think there is now an Emacs lib fixing the issue for you by setting the proper paths:


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.