3

When lsp-ui-doc offers me information about the symbol at point, it does that in a hover window (good) and in the minibuffer (bad).

I've found no mention of the minibuffer in the customisations of lsp-*

Can you please tell me where/how to disable the use of the minibuffer in lsp-ui?

2 Answers 2

2

I think this is not related to lsp-ui. I do not have lsp-ui installed and still got annoying previews in the minibuffer in lsp-latex. Turning off eldoc-mode has solved it for me.

3

As @sergolala hints, this is eldoc related, but turning off eldoc is not the answer.

Instead, see the customizable variable lsp-eldoc-render-all. There is some discussion of this variable on github issues (Setting lsp-eldoc-render-all to nil can still show multi-line text, lsp-mode doesn't display signatures in Rust when lsp-eldoc-render-all is nil), but the documentation for the variable reads:

Display all of the info returned by document/onHover. If this is set to nil, eldoc will show only the symbol information.

However, you may want to just set lsp-eldoc-enable-hover to nil:

If non-nil, eldoc will display hover info when it is present.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.