2

When I try to use auto-completion with lsp + rust-analyzer, all functions inserted like that:

shared_state.clone_from(${1:source})$0

I cannot find any way to disable this "arguments". I don't even understand what package is inserting this (I use prelude bundle + company). Replacing rust-analyzer with rls as language server helps, at least it looks like:

shared_state.clone_from

when I hit "Enter", which is better, cuz I don't need to remove anything.

Any advise or help would be much appreciated, thx.

Update 1

Okay, I looked at lsp log, and seems like this (${1:source})$0 is raw response from rust-analyzer. So now I need to think a way to convert this representation to something, what, I suppose company, will be able to use.

1

Okay, seems like I missed part that yasnippet should be enabled. yas-minor-mode fixed it.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.